Pool Closure Notice
Minor incident
Montecito Family YMCA
Outdoor pool
2026-06-23 08:15 AM PDT
· 3 hours, 44 minutes
Updates
Update
June 23, 2026 · 10:40 AM PDT
Members, Our pool is now opened and we look forward to seeing you soon. Thank you for your patience and understanding.
Issue
June 23, 2026 · 08:15 AM PDT
Due to an unexpected mechanical issue, the pool is temporarily closed. Our team is working to resolve the problem as quickly as possible and will provide updates as they become available.
We apologize for the inconvenience and appreciate your patience.
← Back
Status for Channel Islands YMCA Branches